Netscape 7; The Need For Standards

28th August 2002 · Last updated: 5th October 2016

At last! The final version of Netscape 7 is here! Since it's based on Mozilla 1, it has to be good this time. Netscape 4, you're officially dead! (Discuss)

Confirming The Need For Standards

If you've ever tried to convince someone they need to make their website comply with the W3C standards, then point them to this article. Sorted! (Discuss)